Create 3D Model Like Nine Samples

Feb 15, 2012 at 10:33 AM

Hello,

First of all i'm sorry if this topic is should not be here,,

but i,m really courious about how you make your .x extension like peon.x so it can support multiple animation

I'm currently make 3D animation using Maya, and 3DSMax, it just support one timeline so it can't be multiple animation

but i read at older post that you export your peon.x from 3ds max using panda x exporter, 

i haven't tried using panda x, but can panda X split animation from 3ds max, so it can be loaded like your skinnedgame3D example??

Thanks...

Coordinator
Feb 15, 2012 at 10:35 AM
Yes
Feb 16, 2012 at 8:40 AM

Hi, i had tried to export my 3D object to .X using Panda X and kW Exporter,

but when i load it in XNA using Nine Pipeline,i don't know why my Model.Tag always null, therefore i can't load any animation.

Is there any settings in exporting from 3DSMax to .X so that when i load my file so that Tag properties not null???

When i open my <filename>.X in visual studio, it has poperties Animation Set <animation-name>, so i think it is ready to load animation...

Thanks before..

Nb: should i post this in new discussion? if so, then just tell me, and i will post it in new discussion, still new in here :p

Coordinator
Feb 16, 2012 at 9:30 AM
Have you set the processor to "Model - Engine Nine" ? If you have installed DirectX SDK, there is an X file viewer tool so you can see if the animation was exported propertly.
Feb 16, 2012 at 12:16 PM
Edited Feb 16, 2012 at 12:18 PM

emm, sorry i forgot to set the processor parameter, but when i set the parameter this error is occured :

Error 1 Building content threw KeyNotFoundException: The given key was not present in the dictionary.   at System.Collections.Generic.Dictionary`2.get_Item(TKey key)   at Nine.Content.Pipeline.Processors.ExtendedModelProcessor.ConvertMaterial(MaterialContent material, ContentProcessorContext context) in e:\VS2010Project\Nine.1.0.0\Framework\Nine.Content.Pipeline\Processors\ExtendedModelProcessor.cs:line 242   at Microsoft.Xna.Framework.Content.Pipeline.Processors.ModelProcessor.ProcessMesh(MeshBonePair meshBonePair, ContentProcessorContext context)   at Microsoft.Xna.Framework.Content.Pipeline.Processors.ModelProcessor.Process(NodeContent input, ContentProcessorContext context)   at Nine.Content.Pipeline.Processors.ExtendedModelProcessor.Process(NodeContent input, ContentProcessorContext context) in e:\VS2010Project\Nine.1.0.0\Framework\Nine.Content.Pipeline\Processors\ExtendedModelProcessor.cs:line 142   at Microsoft.Xna.Framework.Content.Pipeline.ContentProcessor`2.Microsoft.Xna.Framework.Content.Pipeline.IContentProcessor.Process(Object input, ContentProcessorContext context)   at Microsoft.Xna.Framework.Content.Pipeline.BuildCoordinator.BuildAssetWorker(BuildItem item)   at Microsoft.Xna.Framework.Content.Pipeline.BuildCoordinator.BuildAsset(BuildItem item)   at Microsoft.Xna.Framework.Content.Pipeline.BuildCoordinator.RunTheBuild()   at Microsoft.Xna.Framework.Content.Pipeline.Tasks.BuildContent.RemoteProxy.RunTheBuild(BuildCoordinatorSettings settings, TimestampCache timestampCache, ITaskItem[] sourceAssets, String[]& outputContent, String[]& rebuiltContent, String[]& intermediates, Dictionary`2& dependencyTimestamps, KeyValuePair`2[]& warnings) E:\VS2010Project\SkinnedGame3D\SkinnedGame3D\SkinnedGame3DContent\telur_panda.X SkinnedGame3D

is it has something to do with texture and material??

 i had 3d viewer to view my model and the animation is running, i don't have the directX viewer...

 

thanks..

Coordinator
Feb 16, 2012 at 12:19 PM
It seems to be the problem with textures. Which version are you using? I saw it's 1.0.0, so maybe it will work with 1.2.0.
Feb 16, 2012 at 12:22 PM

i'm using version 1.0.0, so i just need to upgrade to 1.2.0??

Coordinator
Feb 16, 2012 at 12:28 PM
It is the problem with loading the default diffuse texture. Is your model textured? If not, the processor will fail in v1.0, this is fixed in v1.2.
Plus, 1.2 provides a lot more features than 1.0, so I suggest you to use version 1.2 instead.
Feb 16, 2012 at 12:32 PM

yes, i haven't made the texture yet, ok i will try the version 1.2

Feb 16, 2012 at 1:24 PM
Edited Feb 16, 2012 at 1:24 PM

i have tried samples from version 1.2, but it seems your skinnedeffect , is it still .xml?? is missing, 

i don't know for sure but, because it is missing so i delete some code about linkedeffect and i think it makes the character not moving, although the bone is moving,,

Can you please give me the skinnedeffect?? maybe via email??

thanks..

Feb 16, 2012 at 1:52 PM

it's solved, i download it from the source code :p

it's animating now...