This project is read-only.

Transparent Textures in Models

Feb 11, 2013 at 11:14 PM
I have a question regarding transparent textures in models.

Right now I have implemented and am adding all of the models I want in my scene, but model textures that contain transparent edges are showing up as all black where they should be opaque. I have tried tracing this through the source code but cannot seem to find where I am missing the depth or alpha state settings. This error even occurs in the sample tutorials, particularly in the leaves for the palm trees if anyone needs a reference.

I have tried all the settings for IsTransparent, though this is using the default model textures, but can't seem to pin this issue down.

Any help would be greatly appreciated, thanks!
Mar 3, 2013 at 11:46 PM
I too am having this issue. I have tried modifying the BlendState, etc, but regardless, all the areas that should be transparent on my models, are black.