This project is read-only.

Localization problems (and solution)

Aug 18, 2011 at 12:04 PM

Hi.

I'm new in XNA dev and after some search for a good engine i tried "NineEngine". I live in France (it's important)

From the release i cannot compile due to "ConvertString" problem so i have download the last version "61356" and compile it through Visual2010 no errors for the FrameWork.

I try to compile the Samples and got some errors about formatException in .fx files, i look at them and they were generated with commas and not dots for float separators (comma is the french float separator...)

To fix this (reading AND writing) :

In Nine.Content.Pipeline / StitchUp / FragmentLinking / Parser / Lexer.cs [Line 141]
    changed
       

return new FloatToken(Convert.ToSingle(_value.ToString()), _path, TakePosition());

    to
    
return new FloatToken(Convert.ToSingle(_value.ToString(), new CultureInfo("en-US")), _path, TakePosition());


You have to add "using System.Globalization;" in top of file


In Nine.Content.Pipeline / StitchUp / FragmentLinking / CodeModel / FloatToken.cs [Line 16]
    changed
       
return Value.ToString();

    to
       
return Value.ToString(new CultureInfo("en-US"));

      
      
You have to add "using System.Globalization;" in top of file

I choose to keep original .fx format and force "en-US", in France the float separator is "," so in .fx it looks like "0,2,0,2,0,2" instead of "0.2,0.2,0.2" just too complicated to parse :)

I tried to run the Samples and they works fine !

I have to check on Xbox now i'll let you know.

Bye and congratulations for your work.

Aug 18, 2011 at 12:35 PM

Thanks for the catch, we are having a lot of localization issues these days, see the previous thread. Will apply the fix soon.

Aug 18, 2011 at 6:30 PM

It works on XBOX too !!

 

On Xbox every Samples is working fine except "Game" , this sample is running at  9fps  and with strange artifacts on the model (some triangles alternate from color to black  while the spotlights are rotating)

I'll try to investigate later i just take a few minutes to test before go to work again..

 

Some tips :

- i'm running in debug mode (normaly other samples go to 60 fps or more)

- i saw a frame limit system in this sample maybe the problem

- i try to remove everything in worldview.xml -> no change..

- i try to change the resolution ->  same problem

- remove all the lights -> same problem

- when i comment "world.draw" - yes it's stupid :) - the frame rate is correct (without anything on the screen except the framerate text)

 

Hope it will help, bye.

Aug 19, 2011 at 2:11 AM
Yes, the game sample is not finished yet, I had spotted some strange issues on Xbox that causes the console to freeze. In fact, the game sample is for the new graphics object model and is still under development :-)