Skeleton doesn't support skinning and modelbatch.draw problem

Feb 24, 2012 at 9:33 PM

Hello,

I have a bit problem with 3D model in engine nine, i'm using engine nine 1.2

I've made my model, but when i tried to draw it using modelbatch.drawskinned it threw an exception :

Skeleton doesn't support skinning 

And if i tried to draw using modelbatch.draw, it threw an exception :

The current vertex declaration does not include all the elements required by the current vertex shader. BlendWeight0 is missing.

But if, i draw it using primitiveBatch.drawSkeleton, the skeleton showed in the screen

What is probably wrong with my model??

thanks..

Coordinator
Feb 26, 2012 at 3:51 AM

Can you show me the stacktrace of "Skeleton doesn't support skinning" ?

Feb 26, 2012 at 8:00 AM

Oh i'm sorry i haven't reply again..

i think it's the problem with panda x exporter

when i exported it with kw exporter it worked like charm,,

but this is the stacktrace

 at Nine.Graphics.Skeleton.GetSkinTransforms()   at SkinnedModel.SkinnedModelGame.Draw(GameTime gameTime) in C:\Program Files (x86)\Engine Nine\v1.2\Samples\Sources\SkinnedModel\SkinnedModel\SkinnedModelGame.cs:line 255A first chance exception of type 'System.NotSupportedException' occurred in Nine.Graphics.dll

i read the source code and i think it's because the bone weight is not exported well by panda X, CMIIW